AlphaControls package

Комментарии

55 комментария(ев)
аватар: Va-Bank
Va-Bank
Дата: Втр, 27/07/2010 - 16:53
Звание: Гуру
Сообщений: 8205

Отличный набор компонентов. Унаследованы все свойства стандартных компонентов. В Delphi 2010 у них есть даже touchmanager. Вообще отключив скины, компоненты выглядят стандартно Smile

аватар: Va-Bank
Va-Bank
Дата: Пнд, 31/01/2011 - 22:18
Звание: Гуру
Сообщений: 8205

Последняя версия компонентов (от 28.01.2011)

аватар: Ghost Rider
Ghost Rider
Дата: Пнд, 31/01/2011 - 22:44
Звание: Посвященный
Сообщений: 409

Вещь!
Va-Bank Good

аватар: Darth_Vaider
Darth_Vaider
Дата: Втр, 01/02/2011 - 00:07
Звание: Посвященный
Сообщений: 503

Где-то это уже было. Вроде на old.vr-online

аватар: Va-Bank
Va-Bank
Дата: Втр, 01/02/2011 - 00:24
Звание: Гуру
Сообщений: 8205

Да тут же это было. Просто я обновил темку. А то последняя версия 6.68 тут была. А это уже год назад было...
Теперь при выходе новой версии буду обновлять эту страничку...

аватар: Va-Bank
Va-Bank
Дата: СБ, 12/02/2011 - 03:26
Звание: Гуру
Сообщений: 8205

Очередное обновление от 11.02.2011

аватар: AnthonySoprano
AnthonySoprano
Дата: СБ, 12/02/2011 - 04:14
Звание: Советник
Сообщений: 933

Sorry Блин. Засада. На Delphi 7 не компилитцо ни один .dpk. Вкратце: Устанавливаю Runtime-пакет (acntD7_R.dpk), говорит что он отказывается устанавливать, т.к. он должен быть design-time. Переключаю в опшинсах с "Run-time only" на "Design-time and run-time", только тогда норм. А тот, что acntD7.dpk - матерится, что не существует класса TsSpeedButton и нескольких других , и не один раз . В окне редактора кода сообщение, что "sAlphaListBox was compiled with different version of sCommonData.TsCommonData."

В общем, ни один пакет не устанавливается так, как должен.
С чем такое может быть связано?

аватар: Va-Bank
Va-Bank
Дата: СБ, 12/02/2011 - 04:13
Звание: Гуру
Сообщений: 8205

Delphi седьмой версии устарела не только морально, но и физически/аппаратно, кому как удобнее Smile Я удивлен еще тому, что под эту версию выпускают компоненты. Интересно. Почему вы не пользуетесь 95 или 98 windows'ом?
Но по сабжу. Удалите все компоненты Alpha из системы, удалите BPL и DCP пакеты. В общем надо сделать так, как-будто вы и не ставили эти компоненты. Потом попробовать поставить заново.
З.Ы. Я сейчас обновил Alpha на своей Delphi 2010 и никаких траблов нет.

аватар: AnthonySoprano
AnthonySoprano
Дата: СБ, 12/02/2011 - 04:22
Звание: Советник
Сообщений: 933

Да я уж всю делфу переставил (заодно удалил всякие bpl и весь неиспользуемый мусор) - не пашет даже на чистый.

А делф седьмой, т.к. мои интернеты не позволяют скачать файл больше 5 мб в час. Такими темпами я до пенсии новый делф не найду...

аватар: AltaVista
AltaVista
Дата: СБ, 12/02/2011 - 16:44
Звание: Мастер
Сообщений: 1812

Цитировать

Почему вы не пользуетесь 95 или 98 windows'ом?

Таки хто ж тэбэ сказал чито не пользуэм? Shy

аватар: milice
milice
Дата: СБ, 12/02/2011 - 18:04
Звание: Наблюдатель
Сообщений: 89

У меня вообще архив запаролен. Скачал версию для D7 и немогу распаковать пароль просит блин.

аватар: AnthonySoprano
AnthonySoprano
Дата: СБ, 12/02/2011 - 19:38
Звание: Советник
Сообщений: 933

Пароль - "масленница" мелкими буквами в английской раскладке. Там на странице загрузки это написано!

аватар: Va-Bank
Va-Bank
Дата: СБ, 12/02/2011 - 19:42
Звание: Гуру
Сообщений: 8205

Прежде чем что-то качать нужно как минимум прочитать что написано на странице разработчика. Надо быть внимательнее. Wink

аватар: Belketre
Belketre
Дата: СБ, 12/02/2011 - 21:29
Звание: Мастер
Сообщений: 1890

AnthonySoprano,
Если до сих пор есть проблемы - удали Delphi и почисти папку Windows\system32 от *.bpl,
затем установи Delphi еще раз

аватар: AnthonySoprano
AnthonySoprano
Дата: Пнд, 28/02/2011 - 06:21
Звание: Советник
Сообщений: 933

Из-за одного этого пакета 2 раза делфу переставил Dash Ничего не помогает... Эххх... пойду старую версию альфы ставить... Sorry

28.02.11
С прошлого раза даже старые версии не ставились. Делф был стерилен, система тоже, ничего от прошлого Alpha не оставалось, но и пачки 7.31 и ниже не ставились. И вот последняя версия встала без шума. Наконец-то! Smile

аватар: Va-Bank
Va-Bank
Дата: ЧТ, 17/03/2011 - 04:55
Звание: Гуру
Сообщений: 8205

11.04.2011 AlphaControls v7.34 Stable released
* Added NOACPNG key in the sDefs.inc file (disables AlphaControls PNG loader, may be useful in systems which have Png support already)
* Fixed error in loading PNG from stream
* Fixed error in initialization of the TsListView drawitems event
* Improved drawing of background in TsCheckBox and TsRadioButton
* Fixed error with leaving of extended border after a program minimizing
* Improved drawing of menuline under Windows 7
* Some improvements in resizing of forms
* Some improvements in the TsSpeedButton drawing
* Improved drawing of buttons in SpinEdits

аватар: AnthonySoprano
AnthonySoprano
Дата: Втр, 12/04/2011 - 23:50
Звание: Советник
Сообщений: 933

Oo Ты насчет этого?
Va-Bank написал(а):

Delphi седьмой версии устарела не только морально, но и физически/аппаратно, кому как удобнее Я удивлен еще тому, что под эту версию выпускают компоненты.

2Кирилл Щербатов
Устареть-устарела, но не мертва, имхо. Сам юзаю, доволен. И не улавливаю связи между "смертью" и "старостью", в плане программного обеспечения.

аватар: Va-Bank
Va-Bank
Дата: СР, 13/04/2011 - 03:10
Звание: Гуру
Сообщений: 8205

Delphi 2010 и выше официально поддерживает WinAPI Windows 7. Все что ниже, на свой страх и риск. Я, например, люблю выпускать не глючный продукт, который точно будет работать на любых системах от XP до Seven включительно.
Сколько людей - столько мнений!

аватар: angryvitum
angryvitum
Дата: ПТ, 15/04/2011 - 12:58
Звание: Посвященный
Сообщений: 552

Ну, Va-Bank, ты даешь! Использовать Win7 API можно и на Delphi 2, единственное, что придется больше кода писать!..

аватар: Va-Bank
Va-Bank
Дата: ПТ, 15/04/2011 - 14:43
Звание: Гуру
Сообщений: 8205

Цитировать

Ну, Va-Bank, ты даешь!

А чего такого? Я сказал ОФИЦИАЛЬНО. Т.е. Delphi 2010 как бы сертифицирована под Windows Seven.
Кстати. Я ставил 2009 делфи, она не пошла как нужно на семерке. Потом в инете где-то нашел, что 2009 делфи не совместима с семеркой. Ставить версии ниже я даже не пробовал. Смысла не вижу.

аватар: Кирилл Щербатов
Кирилл Щербатов
Дата: ПТ, 15/04/2011 - 22:06
Звание: Энтузиаст
Сообщений: 296

Я на 7 с 2009 версией Delphi в прошлом году работу писал на "Созвездие" и в этом. Изза прозрачности панелек и не только... А вообще, конечно, довод про WIN 7 API серьёзный... Послушаюсь совета... Хотя ]]>здесь расписано то]]>, про что говорил angryvitum

аватар: Va-Bank
Va-Bank
Дата: ПТ, 15/04/2011 - 23:31
Звание: Гуру
Сообщений: 8205

У меня 2009 делфи поставилась без проблем на семерку. Но потом я решил накатить апдейты, т.к. они исправляли много багов, в том числе и в IDE. Апдейты не вышло накатить. Ну что же. Решил открыть проект. Скомпилировать. И тут тоже не вышло. Делфи вылетела с ошибкой. После этого я ее удалил. А так на 2009 делфи сидел на ХР.

аватар: Va-Bank
Va-Bank
Дата: ПТ, 16/09/2011 - 03:51
Звание: Гуру
Сообщений: 8205

Наконец-то бетка перешла в стадию стабильная версия. 7.50 от 12.09.2011. ]]>History]]>.

аватар: Exmmm
Exmmm
Дата: ПТ, 16/09/2011 - 18:14
Звание: Энтузиаст
Сообщений: 223

э э э х хы..Молодцы парни..э э э а почему на VR до сих пор нет раздела, откуда бы можно было качать компоненты и всякую-всяченскую-всячену..хы..
а по сабжу про спор на тему "Delphi7 устарела" могучий бобер молвил "Мне приходится на работе вообще на Delphi 6 писать, т.к. без вариантов".
PS: хых дома приду на XE посмотрю что за компоненты, звучит заманчиво.

аватар: Va-Bank
Va-Bank
Дата: ПТ, 16/09/2011 - 19:15
Звание: Гуру
Сообщений: 8205

Цитировать

почему на VR до сих пор нет раздела, откуда бы можно было качать компоненты и всякую-всяченскую-всячену

А смысл забивать диск всякой хренью? Laughing out loud Вот этот раздел как раз и сделан для того, чтобы иметь представление о том, что качаешь и переходишь по указанной ссылке. Все нормуль.

UPD
Заявлена поддержка Delphi XE2 32bit. Плюс некоторые мелкие исправления.

аватар: AltaVista
AltaVista
Дата: СР, 05/10/2011 - 15:57
Звание: Мастер
Сообщений: 1812

Цитировать

Заявлена поддержка Delphi XE2 32bit.

Опечатался, он имел ввиду 64bit.

аватар: Va-Bank
Va-Bank
Дата: СР, 05/10/2011 - 15:59
Звание: Гуру
Сообщений: 8205

Я написал то, что написал:
Цитировать

30.09.2011 AlphaControls v7.51 Stable released
* Added support of Embarcadero DelphiXE2 in 32-bit mode
* Added skinning of TUpDown and TScrollBox components (UpDownBtn and ScrollControl types of skinning in the ThirdParty list)
* Solved problems with skinning in DevEx controls
* Improved work of ExtendedBorders property under Vista/Win7 without Aero
* Many small bugfixes

И я предполагаю что именно 32, так как всегда эти компоненты под 32 бит разрабатывались. А так как в ХЕ2 появился 64бит компилятор, то надо было уточнить, под какую платформу именно были разработаны компоненты.

аватар: VIPER411
VIPER411
Дата: СБ, 12/11/2011 - 00:34
Звание: Наблюдатель
Сообщений: 11

Короче, у меня Delphi 7 винда Windows 7 я поставил AlphaControls нормально, все работает, но готовые проги на XP идут стандартной шкурой (ну как обычно) а на 7 все ОК, выходит на XP шкуры не работают???

аватар: Va-Bank
Va-Bank
Дата: СБ, 12/11/2011 - 01:29
Звание: Гуру
Сообщений: 8205

Все работает и на XP. Какие проблемы конкретно у тебя не знаю, это к разработчику пакета. Можешь добавить его себе в аську и связаться с ним. Он по TeamViewer к тебе подключится и посмотрит что к чему. Ко мне он уже неоднократно подключался, когда у меня затыки были с его компонентами. И это несмотря на то, что для стран бывших СНГ они бесплатны.

аватар: Exmmm
Exmmm
Дата: СР, 04/04/2012 - 13:46
Звание: Энтузиаст
Сообщений: 223

Люди, а в DelphiXE2 и так же вроде скины есть, в чём прикол?

аватар: Va-Bank
Va-Bank
Дата: СР, 04/04/2012 - 16:04
Звание: Гуру
Сообщений: 8205

Там не скины, а стили. Это немного другое.

аватар: DreamChild
DreamChild
Дата: ПТ, 06/04/2012 - 03:25
Звание: Наблюдатель
Сообщений: 6

Хм..интересно, почему многие делфисты едва ли не молятся на седьмую Делфи? Эта среда вышла 10 лет назад, успела устареть настолько, насколько это только возможно, после нее была куча новых версий, выпускавшихся едва ли не ежегодно, а они по-прежнему сидят на седьмой. Ну, допустим, Delphi.NET считается неудачным релизом, но чем этим людям не угодили XE и XE2? Которые превосходят седьмую по всем статьям. Странно как-то даже

аватар: Va-Bank
Va-Bank
Дата: ПТ, 06/04/2012 - 15:32
Звание: Гуру
Сообщений: 8205

Total Commander сделан на делфи. И разработчик до сих пор юзает Delphi 2.
Цитировать

Широко известный факт, что вы до сих пор пишете свой файл-менеджер на допотопном Delphi 2. С чем это связано?
Я являюсь обладателем лицензионных версий всех последних Delphi, поэтому я достаточно хорошо представляю себе их возможности. Но дело тут вот в чем: компиляция exe-файла в Delphi 2 дает на выходе файл, ощутимо меньший по размеру, чем, например, в Delphi 7. Кроме того, тестирование показывает, что exe'шник из-под Delphi 2 работает заметно быстрее, чем его полный аналог, выпущенный компилятором Delphi 7. Я сталкиваюсь с тем, что люди часто удивляются, что Total по-прежнему работает очень быстро. Я собираюсь сохранить эту его особенность, и отчасти секрет тут в правильно выбранном компиляторе.
Добавлю, что, кроме того, Delphi 2 генерирует очень универсальный код, например, с полной поддержкой 16-битовых приложений или Windows 95/98 - у меня до сих пор хватает таких клиентов. В то же самое время TC прекрасно себя чувствует и в Windows 7.

аватар: DreamChild
DreamChild
Дата: ПТ, 06/04/2012 - 17:49
Звание: Наблюдатель
Сообщений: 6

Ну тогда уж можно вообще на ассемблере писать, скорость будет адовой:) Тем более, в случае с Тоталом скорость работы ограничивается скоростью чтения/записи данных на диск, а тут уж компилятор вряд ли поможет. Не мне ,конечно же, учить этого парня что и на чем писать, но все же Delphi 2 - это оригинально))

аватар: Va-Bank
Va-Bank
Дата: ПТ, 06/04/2012 - 18:38
Звание: Гуру
Сообщений: 8205

Но я сам сторонник нового, но стабильного. Сам юзаю Delphi XE 2 Update 4. Ибо со времен Delphi 7 стандартные компоненты столько могут, что теперь никакие сторонние паки компонентов не нужны (ну почти, альфаконтролс как исключение Laughing out loud)

аватар: DreamChild
DreamChild
Дата: ПТ, 06/04/2012 - 20:53
Звание: Наблюдатель
Сообщений: 6

Ну в плане оформления интерфейса, имхо, очень хорош WPF от мелкомягких.Если же говорить о самой IDE, то предположу, что энное количество программистов сидят на старых версиях еще и потому что CodeGear (как и Борман в прошлом) не балует людей экспресс-версиями и прочими вкусными штуками, которые есть у Microsoft (взять хотя бы ту же программу DreamSpark). А цена на основные лицензии RAD Studio сильно кусается. Это что касается более-менее серьезных контор, которые себе не могут позволить пользоваться пиратками. А если говорить об обычных студентах, которые качают IDE из торрентов, то они, скорее всего, кодят на том, что им показывали в институтах

аватар: Va-Bank
Va-Bank
Дата: ПТ, 28/09/2012 - 18:41
Звание: Гуру
Сообщений: 8205

Цитировать

28.09.2012 AlphaControls v8.00 Beta released
* Added support of 64-bit compilers
* Added new TsTitleBar component (buttons, tabs and other elements in a form title when AlphaSkins are Active)
* Added new TsSkinProvider.TitleIcon.Visible property
* Popup calendar and calculator are shown without activating
* Added support of fourth state (Default button) in buttons
* Added many new graphic procedures for drawing on bitmap with alpha-layer
* Removed some deprecated properties and procedures with saving of backward compatibility
* A lot of improvements and optimizations in the code
* Added new "Black box" skin (by Graf Sascha)
24.09.2012 AlphaControls v7.70 Stable released
* Improved text drawing in TsButton when skins are disabled
* Solved issue with glowing in buttons when they moved by mouse wheeling
* Solved issue with mouse wheeling in the TsListbox
* Added new TsSkinManager.OnGetPopupItemData event for menu items customization
* Solved issue with a forms resizing
* Added support of the RAD Studio XE3 x32

аватар: Максим Сысоев
Максим Сысоев
Дата: Пнд, 01/10/2012 - 02:24
Звание: Наблюдатель
Сообщений: 3

Проблема-не могу установить бетку на ХЕ2.
Цитировать

[DCC Fatal Error] acntDelphiXE2_x64_R.dpk(1): E2225 Never-build package 'acntDelphiXE2_x64_R' must be recompiled
[DCC Fatal Error] acntDelphiXE2_x64.dpk(33): E2202 Required package 'acntDelphiXE2_x64_R' not found

хотя я открывал acntDelphiXE2_x64_R и заново компилировал его...

аватар: Va-Bank
Va-Bank
Дата: Пнд, 01/10/2012 - 03:24
Звание: Гуру
Сообщений: 8205

Все вопросы на ]]>форум]]> разработчика, там ответят что вы делаете не так. Я бетку ставил 32 бит, все равно пока под 64бит приложения не делаю.

аватар: XCaHeK
XCaHeK
Дата: ПТ, 14/03/2014 - 22:32
Звание: Наблюдатель
Сообщений: 4

У меня к вам вопрос простой, я установил АlphaControls но понятие не имею где они находятся и как их использовать. P. S. Я новичок в Delphi, так что извините если вопрос от нуба... Smile

аватар: Va-Bank
Va-Bank
Дата: ПТ, 14/03/2014 - 22:48
Звание: Гуру
Сообщений: 8205

Если все установлено верно, то в делфи в палитре компонентов появятся новые вкладки:
AlphaAdditional, AlphaStandart, AlphaTools
Если ставили дополнительно DB-компоненты, то появится вкладка:
AlphaDBControls
Используются как обычные компоненты. Чтобы лучше узнать что к чему можете скачать исходники демо-примера и открыть их у себя в своей IDE. Дабы понять что к чему. Качать вот с ]]>ЭТОЙ]]> страчники. Ссылка называется "Compiled demo". Качайте ту демку, какой версии у вас стоят компоненты.

аватар: XCaHeK
XCaHeK
Дата: СБ, 15/03/2014 - 17:56
Звание: Наблюдатель
Сообщений: 4

Устанавливал все по вашему видео. Полностью идентично. Ошибок не было. Но в delphi вкладки не появились. В чем может быть проблема?

аватар: Va-Bank
Va-Bank
Дата: СБ, 15/03/2014 - 18:20
Звание: Гуру
Сообщений: 8205

Ни разу такого не было чтобы не появились вкладки. Но я не ставил бету 9 версии. Может в этом проблема? Какую версию вы поставили? Демку пробовали открывать у себя в делфи? Ругается или открывается без проблем?

аватар: Belketre
Belketre
Дата: СБ, 15/03/2014 - 20:58
Звание: Мастер
Сообщений: 1890

Попробуй вручную установить, в папке, куда ты устанавливал, должна быть инструкция

аватар: Va-Bank
Va-Bank
Дата: СБ, 15/03/2014 - 22:28
Звание: Гуру
Сообщений: 8205

Ну так вручную компоненты и устанавливаются. Автоинсталлятора нет у альфаконтролс

аватар: XCaHeK
XCaHeK
Дата: ВС, 16/03/2014 - 01:14
Звание: Наблюдатель
Сообщений: 4

Последняя стабильная версия (v8.53, 23.01.2014). Я вот эту ставил. И как открыть демку в делфи не понимаю...

аватар: Va-Bank
Va-Bank
Дата: ВС, 16/03/2014 - 06:23
Звание: Гуру
Сообщений: 8205

1) ]]>Мануалы на русском языке на офсайте]]>
2) ]]>Исходники демки версии 8.53]]>. Необходимо разархивировать исходники. Открыть файл проекта ASkinDemo.dpr в делфи.

аватар: XCaHeK
XCaHeK
Дата: ВС, 16/03/2014 - 20:22
Звание: Наблюдатель
Сообщений: 4

Спасибо, попробовал по мануалу и все получилось. Большое спасибо.

аватар: Va-Bank
Va-Bank
Дата: ЧТ, 24/07/2014 - 15:14
Звание: Гуру
Сообщений: 8205

Версия 9.12 уже в разряде стабильных (может девятка и раньше уже стала стабильной, но я пропустил этот момент). Архив весит теперь не 10 метров, а всего 2 мегабайта. Из архива убраны файлы скинов и вместо них теперь красуется обычная ссылка на страничку загрузки этих самых скинов. И действительно, так же проще. Тем более на сайте есть превью всех шкурок.

аватар: Va-Bank
Va-Bank
Дата: СБ, 30/08/2014 - 00:36
Звание: Гуру
Сообщений: 8205